[ESS] Problem with ESS / R / tracebug under OS X

Rainer M Krug Rainer at krugs.de
Wed Jun 26 09:59:54 CEST 2013


I migrated from Linux to Mac OS X and I am experiencing the following
problem in ESS / R with tracebug:

When I run code (in a package) and an error occurs, the location is not
shown correctly, but only <text> instead:

| sh: line 1: 62906 Trace/BPT trap: 5 'r.param.scale'
| --interface-description >
| /var/folders/50/wcr5bjwn75q595n6x82gxj280000gn/T//RtmpsB4JC1/filef5007f3e9ee7'
| 2>
| /var/folders/50/wcr5bjwn75q595n6x82gxj280000gn/T//RtmpsB4JC1/filef50047393ea0'
| Error in if (file.exists(file) == FALSE) if (!missing(asText) && asText ==  : 
|   argument is of length zero
| Error in parseGRASS(cmd, legacyExec = legacyExec) (from <text>#150) : 
|   r.param.scale not parsed

I tried it with starting emacs with -q and only loading ess 5.14, but
still the same as using the one from git.

Any suggestions?


Rainer M. Krug

email: RMKrug<at>gmail<dot>com

More information about the ESS-help mailing list