[ESS] ESS does not find Rterm.exe on Windows

Neuwirth Erich erich.neuwirth at univie.ac.at
Sun Jun 2 09:45:41 CEST 2013

I am definitely not an ESS expert, so somebofy might know a better way.

In my .emacs I do

(setq-default inferior-R-program-name
	      "C:/Program Files/R/R-2.15.1/bin/x64/Rterm.exe")
(setenv "PATH" (concat "C:\\Program Files\\R\\R-2.15.1\\bin\\x64" ";"
    (getenv "PATH")))

(require 'ess-site)

On May 31, 2013, at 5:15 PM, Wolfgang Ramos <ramos at psychologie.uni-kiel.de> wrote:

> Hi,
> I installed R in a directory called "X:\alphaAndOmega\R\R". So Rterm.exe
> (32-Bit version) is located in "X:\alphaAndOmega\R\R\bin\i386". I know that
> it's not a 'standard R-directory' and that "standard R-directories", like
> R-3.0.0 are easily recognized by ESS (at least if I add them to my PATH
> variable in Windows).
> I tried customizing my .emacs file in a way, that ESS would look for
> Rterm.exe in my non-standard directory, but I wasn't able to do so. I'm
> absolutely new to emacs and i tried playing around wird some of the
> following commands:
> inferior-R-program-name
> ess-rterm-version-paths
> But I failed. ESS doesn't find anything.
> I use emacs 24.3.1, ESS 13.05 and R 2.15. At the moment my .emacs file
> contains just one line:
> (require 'ess-site)
> What can I do to make ESS find my Rterm.exe? I could really need some help...
> ______________________________________________
> ESS-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list