[ESS] ess-julia.el

Jay Kerns gjkernsysu at gmail.com
Sat Feb 23 14:07:45 CET 2013

Dear ESS-help,

I have a few comments and questions about ess-julia.el:

1. Great work! Thanks for this.

2. I notice after M-x julia there is a 'load' statement which issues a
warning about being deprecated and that 'require' should be used
instead.  I found the place in ess-julia.el where that is (there looks
to be 2 places, actually), and I fixed those, but I haven't committed
to my fork yet because I wanted to ask about #3 first.

3. I notice after M-x julia that the process doesn't echo to the
buffer.  I understand that in the iMenu there is a checkmark for
"Process Echoes" and I can get the process to echo.  This is
different, of course, from R (and gretl, it appears) which echo the
process by default.

I tracked it down to the following line in ess-inf.el:

Line 2194 of /lisp/ess-inf.el
(not (member ess-language '("SAS" "XLS" "OMG" "julia")))) ;; these don't echo

So it looks like somebody deliberately wanted julia not to echo.  My
question is, "Why?"  Is there a reason that would be easy to describe?
 And if there is a reason, is there a setting I can use (in .emacs or
elsewhere) to enable process echoes on my personal system?  (Yes, I
can click the button, but it would be helpful in other work I'm doing
for julia processes to echo by default).

By the way, I've already tried numerous global settings, but since
comint-process-echoes is buffer local that line "2194" overrides
everything I've tried so far.

Thanks again, and again, great work.


More information about the ESS-help mailing list