[ESS] Fwd: ess sas interactive (remote)

Vitalie Spinu spinuvit at gmail.com
Sun Aug 11 16:57:31 CEST 2013

 >> Rodney Sparapani <rsparapa at mcw.edu>
 >> on Fri, 14 Jun 2013 09:05:07 -0500 wrote:

 > On 06/13/2013 10:24 AM, Rodney Sparapani wrote:
 >> So when you launch ess-sas-interactive you get ess-process-name-list
 >> set to (("shell"))  But, when you have a .sas file and try to submit
 >> a line then it becomes (("SAS") ("shell"))  Can we do something to
 >> fix that?

 > What is the intended way of fixing this?  I have tried setting
 > ess-local-process-name, ess-language or ess-dialect:  all
 > to no effect.  But, I only tried these one at a time.  Am I
 > on the right track?  I guess not because nothing is working.

I just committed a couple of changes to SVN. Could you please check if
it works.

You are not setting ess-dialect, There is no way to connect to a buffer
if it is not marked by ess-dialect variable.

What is the difference (with respect to SAS) between ess-remote and
ess-sas-interactive Would it make sense to move a couple of lines from
ess-sas-interactive into ess-remote and to deprecate ess-sas-interactive


More information about the ESS-help mailing list