[ESS] ess-developer

Vitalie Spinu spinuvit at gmail.com
Tue Apr 23 22:37:30 CEST 2013

 >> Vitalie Spinu <spinuvit at gmail.com>
 >> on Tue, 23 Apr 2013 20:57:34 +0200 wrote:


 > ESS-developer handles correctly s3 methods registered locally in your
 > own package, but it doesn't look for methods registered in other
 > packages (like AIC in your example).

I was confused here. AIC is defined as an S3 method in stats. So, when
you develop stats package ess-developer handles AIC.default correctly
and inserts it, as R expects, both in the namespace and local S3 table.


You can see that it also worked for you. getAnywhere reports only one
object. There is nothing wrong here:

 R> # ESS: source new function C-c C-f
 R> getAnywhere('AIC.default')
 >> A single object matching 'AIC.default' was found
 >> It was found in the following places
 >> registered S3 method for AIC from namespace stats
 >> namespace:stats
 >> with value

So your original problem is a really different situation. Is your
package on CRAN? Can you provide a reproducible example with your

 >> <srcref: file "c:/x/bug.r at 1" chars 1:16 to 27:1>
 >> <environment: namespace:stats>
 >> Warning message:
 >> In file(srcfile$filename, open = "rt", encoding = encoding) :
 >> cannot open file 'c:/x/bug.r at 1': No such file or directory

This messup with function printing is solved in ESS dev.


More information about the ESS-help mailing list