[ESS] Noweb problem after upgrade to ESS 12.09

ottorino ottorino-luca.pantani at unifi.it
Fri Oct 12 12:09:52 CEST 2012

Il giorno mar, 02/10/2012 alle 13.14 +0200, Vitalie Spinu ha scritto:
> >> r <ric.romoli at gmail.com>
>   >> on Tue, 02 Oct 2012 00:58:30 +0200 wrote:
>   > Hello, 
>   > I installed ess latest version (ess-version : 12.09) a few days ago. I
>   > work with Linux Ubuntu 10.04 (Lucid) and emacs 23.1.1. After the ess
>   > upgrade I notice troubles working with noweb files (.Rnw)
>   > In particular I have the following error: 
>   > File mode specification error: (void-function noweb-mode)
> Our noweb was renamed into ess-noweb-mode to avoid conflicts with the
> real noweb-mode (see new features in the announcement). Remove all the
> occurrences of noweb-mode in your .emacs and it should be ok.
>     Vitalie

Hi all,
I'm experiencing the same problem here.
Please forgive me if thi mail is long, tedious and may be unnecessarily
over-detailed. My aim is to try to give all the relevant information to
you experts.

Until I had this configuration
Ubuntu 10.04 -- GNOME 2.30.2
GNU Emacs 
(x86_64-pc-linux-gnu, GTK+ Version 2.18.0)
ESS version 12.04 -- R 2.15.0

I had no problems

Now I've changed to 
ESS version 12.09 -- R 2.15.1
and I'm experiencing problems with Sweave.

Here are the lines in my .emacs file in which is written "noweb"

 (defun Rnw-mode ()
   (require 'ess-noweb)
   (if (fboundp 'R-mode)
       (setq noweb-default-code-mode 'R-mode)))

I tried to comment like this, as suggested by Vitalie

(defun Rnw-mode ()
   (require 'ess-noweb)
   (if (fboundp 'R-mode)
       (setq noweb-default-code-mode 'R-mode)))

but when I open an Rnw file I cannot get the noweb mode and in messages
appears the following

> File mode specification error: (void-function noweb-mode)

Then I tried to substitute noweb-mode with ess-noweb-mode, 
as far I can understand from the announcement 

> * ESS[R] noweb: `noweb-mode' and `noweb-font-lock-mode' have
>           been renamed to `ess-noweb-mode' and
>           `ess-noweb-font-lock-mode' to avoid conflicts with the
> "real"
>           `noweb-mode'.
>         * ESS[R] noweb: The long standing font-lock bug has been
> solved
>           in `ess-noweb' interface

(defun Rnw-mode ()
   (require 'ess-noweb)
   (if (fboundp 'R-mode)
       (setq noweb-default-code-mode 'R-mode)))

In this case I can open a Rnw file and get all the colors for sweave
sintax and pulldown menu for "noweb" 

On the buffer 'messages' appears the following

> For information about GNU Emacs and the GNU system, type C-h C-a.
> noweb mode: use `M-x noweb-describe-mode' for further information
> Fontifying from 0 to 2
> Automatic display of crossref information was turned on
> Setting up syntax table
> Fontifying documentation chunks: chunk 0
> Fontifying documentation chunks: chunk 1
> Fontifying documentation chunks: chunk 2
> About to do code chunks
> Fontifying code chunks: chunk 1
> ESS-style: C++
> noweb-font-lock mode: use `M-x noweb-font-lock-describe-mode' for more info
> ESS-style: C++ [2 times]

and in ESS buffer a lot of lines ending with 
> Finished setting up ESS-mode.

I can see the 'M-x noweb-describe-mode' but there's no 
'M-x noweb-font-lock-describe-mode'. 
The only modes are:

> Possible completions are:
> noweb-font-lock-fontify-buffer 	
> noweb-font-lock-fontify-chunks
> noweb-font-lock-fontify-this-chunk
> noweb-font-lock-initial-fontify-buffer
> noweb-font-lock-minor-mode

The problem is that I cannot get Sweave to work.

On 'M-n-s' 
(that is "process this file with Sweave")
in the buffer 'messages' I get:

> Applying style hooks... done
> Sorting environment...
> Removing duplicates... done
> no ESS processes running; starting R
> Type C-h m for help on ESS version 12.09
> Cannot read history file /home/ottorino/Documenti/analisiGigi/nuova/.Rhistory
> get-ess-process: No ESS process is associated with this buffer now

In the ESS buffer I cannot read any error message.
In R buffer I read

> > assignInNamespace(".help.ESS", help, ns=asNamespace("base"))
> options(STERM='iESS', str.dendrogram.last="'", editor='emacsclient', show.error.locations=TRUE)

Finally I tried to comment out all the lines in my .emacs like this
> ;;  (defun Rnw-mode ()
> ;;   (require 'ess-noweb)
> ;;   (ess-noweb-mode)
> ;;   (if (fboundp 'R-mode)
> ;;       (setq noweb-default-code-mode 'R-mode)))

but I stil get the same problems and messages as the case immediately above.

>From the shell everything is working fine and I can do 

R CMD Sweave Gigi\ II.Rnw

without any problem.

Any suggestion ?

Thanks in advance for your time.


More information about the ESS-help mailing list