[ESS] 3 separate Emacs-ESS SAS problems

Paul Johnson pauljohn32 at gmail.com
Fri Nov 23 05:57:53 CET 2012

I solved problem 2 below explained.

On Wed, Nov 21, 2012 at 5:05 PM, Paul Johnson <pauljohn32 at gmail.com> wrote:
> Hello, Rodney
> I'm back to say I've isolated the 2 separate SAS problems.
> 1. As you explained, there's a difference between "local" and
> "global". I don't know how to make local work (tried plenty...).  This
> in init.el does not cause errors at start time
> (load "ess-site")
> (ess-sas-global-unix-keys)
> But I can't find any example where the local variant works. It always
> returns the keymap is nil, the error I mentioned before.
> 2. filename.sas -> *shell* mysteriously!
> If I open a SAS file and hit F3, it tries to do what it is supposed
> to, but the string "*shell*" is sent to the on the command line where
> it should see the SAS filename. This is the output in Emacs *shell*
> buffer
> cd /tmp/flop.sas/
> nohup nice sas *shell* -rsasuser &
> [1]+  Exit 102                nohup nice sas *shell* -rsasuser
> pauljohn at pjlap-124:flop.sas$ pauljohn at pjlap-124:flop.sas$ [1] 6472
> pauljohn at pjlap-124:flop.sas$ nohup: ignoring input and appending
> output to `nohup.out'

Here's the explanation for the problem. I had .sas suffixed to the
directory that held the sas files


Hitting F3 causes the malfunction I described above.  The file name
"flop" is changed to *shell* and the thing fails.  It appears that any
directory name ending in .sas kills the batch SAS usage.

As long as I don't name a directory .sas, though, it works fine:)

I'm still working on the interactive SAS, but I'm making progress
there and will let you know.

Paul E. Johnson
Professor, Political Science      Assoc. Director
1541 Lilac Lane, Room 504      Center for Research Methods
University of Kansas                 University of Kansas
http://pj.freefaculty.org               http://quant.ku.edu

More information about the ESS-help mailing list