[ESS] Install experiences

Ross Boylan ross at biostat.ucsf.edu
Thu Jun 21 02:54:17 CEST 2012

I recently had Windows 7 installed on a computer, and then R 2.15 and 
emacs 24.1.  ESS 12,04-4 is now working, but I thought I'd mention a 
couple of rough spots.  My hope is that this report might lead to some 
improvements in the installation  experience and documentation.

I've installed and used ESS before on a number of linux and windows 
systems.  I think I've often used Vincent Goulet's packages for Windows, 
but since I already had emacs I didn't this time.

First, I tried using emacs' new package management system, but ESS 
wasn't in it.  You might consider using that distribution channel.

Second, when I went to download the file from 
http://ess.r-project.org/index.php?Section=download it was hard to find 
instructions.  The first paragraph says "To run ESS in Emacs you have to 
first download the compressed eLisp source files and install them 
according to the following instructions."  But there aren't really any 
instructions on the page.  Eventually I tried the link to the ESS manual 
at the bottom, although the description "Instructions on how to retrieve 
ESS in particular or how to work with Subversion in general can be found 
in the following documents:" was not too inviting.  First, it didn't say 
which was which (it's pretty easy to guess, but why add friction?  The 
git docs are clearly marked off); more importantly, my problem was not 
how to retrieve the code but how to install it.  After some searching 
around in the manual I found the relevant section, which is also in the 
README file at the top of the directory of the unpacked zip.

Finally, when I followed the instructions to install, I got to the 2nd 
step and was happy about the "you're done."  When I tried to start R it 
didn't work ("rterm not found").  Only then I realized I did not have an 
ESS buffer, and even the instructions after the second step did not say 
how to deal with rterm trouble, except to email this list.  A little 
more searching solved that too, although the instructions contain one 
more pitfall, I think.  The paragraph above the one with (setq 
inferior-R-program-name "...") ends with the advice to "make sure to use 
backslashes, '\' since Windows requires them."  Despite that, the setq 
example uses forward slashes and I suspect backslashes would be 
interpreted as escapes by elisp and fail, unless doubled.

I'm not sure if ESS is supposed to be able to find R automatically; I 
recall some discussion about that quite awhile ago.  FWIW, my 
installation was at 
c:/Users/rdboylan/Documents/R/R-2.15.0/bin/i386/Rterm.exe. That's where 
the system adminstrator put it.

Thanks for ESS!

I don't need any particular response.


More information about the ESS-help mailing list