[ESS] My Emacs presentation yesterday; OK but can't save transcript

Paul Johnson pauljohn32 at gmail.com
Wed Aug 29 16:52:04 CEST 2012

Thanks to all of your feedback last week about my Emacs Sales pitch,
"Emacs has no learning curve".  I took the document out of LyX and
worked on the last several drafts in Emacs, so as not to be such a
massive hypocrite as I was before.

I made some helpful changes in response to your advice, in case you
want to point your customers, er students, here, go ahead (source in
same folder).


I still am standing by my original claim that ordinary people can use
Emacs, even if they don't do Lisp.

In class we have a vanilla Windows computer on which they let me
install what I want, so I downloaded Professor Goulet's Emacs
24.1-modified and it installed beautifully.  I notice some interesting
changes in the Emacs menu names this time.  From 22 to 23 we saw the
elimination of "kill buffer", now from 23 to 24 we have no more "split
windows".  Re-label things to keep teachers on their toes, I expect.

I ran into one trouble, and I don't know if problem is ESS or Emacs or Windows.

While editing flop.R, and interacting with the *R* buffer, I wanted to
save flop.Rout,  but could not.  When I clicked "File -> Save As" in
there, and choose a file name, upon return Emacs bell sounds and the
minibuffer says "Text is read only".   The *R* buffer itself, as
displayed on the screen, is not marked read only (No %% in status

The only thing I could think of was to start a new, empty buffer and
select all and copy into it from *R*, which seemed not efficient.

Have you experienced this?  I don't see it in Linux with emacs 23X

Paul E. Johnson
Professor, Political Science    Assoc. Director
1541 Lilac Lane, Room 504     Center for Research Methods
University of Kansas               University of Kansas
http://pj.freefaculty.org            http://quant.ku.edu

More information about the ESS-help mailing list