[ESS] ess-r-args-show SOLVED

Patrick Connolly p_connolly at slingshot.co.nz
Fri Aug 19 11:23:37 CEST 2011

On Mon, 15-Aug-2011 at 08:22PM +0200, Sven Hartenstein wrote:

|> Hi,
|> not an answer to your question, but you might like r-autoyas, which
|> inserts the arguments as a yasnippet.
|> Details: http://www.svenhartenstein.de/Software/R-autoyas
|> Screencast of old version: http://www.youtube.com/watch?v=jLJPorf2LBE

I had to wait until everything quietened down before I could hear what
what that Youtube clip was about.  Very low volume.  Looks like it
doesn't do anything we can't do with 'ess-r-args-insert and then a bit
of Emacs editing.  But thanks for the suggestion and to Stephen,
Michael, Felix and Rodney for other suggestiions.

I think I eveentually worked it out.  The DOS file thing was a
red-herring.  The important thing was the associating the .R file with
a *R* buffer.  Someone mentioned it, but I wasn't aware of what was
necessary to do so.  I thought that if I opened a .R file from within
the same Emacs session I'd used to begin R that would happen.  Not so.  

I make use of this line I have in my .emacs file

(global-set-key [f1] 'ess-eval-line)

If I press the F1 key from any line in the .R file, there's an attempt
to run that "command" in the *R* buffer, in the process associating
the .R file with that buffer.  Anyone else who hasn't got it to work
might be under the same misapprehension I was under.

For the record, what works in my .emacs file in a Fedora 15 box is

(load "~/local/ess-5.14/lisp/ess-site")
 (require 'ess-eldoc)
(setq ess-r-args-electric-paren t)
(add-hook 'inferior-ess-mode-hook 'ess-use-eldoc)

That has it working in both .R and *R* buffers.


   ___    Patrick Connolly   
 {~._.~}                   Great minds discuss ideas    
 _( Y )_  	         Average minds discuss events 
(:_~*~_:)                  Small minds discuss people  
 (_)-(_)  	                      ..... Eleanor Roosevelt

More information about the ESS-help mailing list