[ESS] ESS 5.8 installation for Xemacs 21.5.29 of May 2009 under opensuse 11.2 x86_64

Rodney Sparapani rsparapa at mcw.edu
Fri Mar 26 15:37:26 CET 2010

On 03/25/10 06:31 PM, Martin Burschka wrote:
> Dear ESS team,
> I have tried 2 ways of installation:
> 1. one-click installation from
> http://software.opensuse.org/ymp/home:dsteuer/openSUSE_11.2/emacs-ess.ymp
> 2. extraction of the ess-5.8.tgz download to
> /usr/local/share/xemacs/site-packages
>      and adding the line (load
> "/usr/local/share/xemacs/site-packages/ess-5.8/lisp/ess-site") to my
> ~/.xemacs/init.el file
>      via the options/edit-init-file menu option in Xemacs.
> I have not changed anything in the ess-site.el file.
> However, whatever I do, I do not get the *ESS* buffer as I am led to expect
> by /usr/local/share/xemacs/site-packages/ess-5.8/doc/readme.pdf
> when I start Xemacs.
> I get the following two lines in the Xemacs window at the bottom:
> UTF8-----L1 C0 All     *scratch* (Fundamental)---------------------------
> Loading this file requires xemacs, (null (function-max-args 'throw))

I think that should have worked.  Are you using XEmacs stable or beta?

> When I click in the window the lower line goes blank.
> When I invoke M-x R, I get "[No match]"
> My R version is 2.10.1 (2009-12-14)
> and it does start when I invoke it as "R" in a terminal window.
> Do you have a How2 or a FAQ for Xemacs-ESS installation questions?
> What can I check?
> Best regards
> Martin Burschka


First, you will see the GNU Emacs instructions, and the XEmacs 
instructions follow.  However, these instructions are for stable
only since there is a bug/feature in XEmacs beta that requires an
extra step that I have not documented since beta is not supported.



More information about the ESS-help mailing list