[ESS] "Sorry, no version of R could be found on your system", for new version of R 2.12

Evan Misshula emisshula at jjay.cuny.edu
Sun Dec 19 16:23:44 CET 2010

From: spencerg [spencer.graves at prodsyse.com]
Sent: Sunday, December 19, 2010 5:50 AM
To: Evan Misshula
Cc: ess-help at stat.math.ethz.ch
Subject: Re: [ESS] "Sorry, no version of R could be found on your system", for new version of R 2.12

1.  What do you get for "system.files()" from within R?  The first part
should match what you have in site-start.el.  For example, I find the


       site-start.el includes:

       (setq-default inferior-R-program-name
Is it possible that it did not install correctly.  Here is the output from system.files()...

> system.files()
Error: could not find function "system.files"
> sessionInfo()
R version 2.12.1 (2010-12-16)
Platform: i386-pc-mingw32/i386 (32-bit)

[1] LC_COLLATE=English_United States.1252 
[2] LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

2.  If this fails to fix the problem, might you have more than one
"(setq-default inferior-R-program-name ...)" statement in
"site-start.el"?  I have only one.  (To be precise, I have many that
start ";(setq-default ...)".  However, ";" indicates a comment.)

I don't read lisp that well but everything else seems commented.  Should I attach the whole file?

3.  If the above fails to fix the problem, maybe you have multiple
site-start.el files?  You might change one while the system uses another?

I did a find file on windows explorer and it only returned one site-start.el (and one site-start.el~).

I noticed that it requires 

(require 'ess-site)
(require 'ess-eldoc)

Could the conflict come from those files?

Thanks for your prompt and helpful response.  Best, 

Evan Misshula
CUNY John Jay

hope this helps.

On 12/18/2010 10:22 PM, EvanMisshula wrote:
> I am having the same problem but I have added
> (setq-default
>        inferior-R-program-name
>                "C:\Program Files\R\R-2.12.1\bin\i386\Rterm.exe")
> site-start.el file.  I have also added to my path, C:\Program
> Files\R\R-2.12.1\bin\i386\.  It is still not working.  Does anyone see what
> I am doing wrong.
> Many thanks,
> Evan Misshula
> Stephen Eglen wrote:
>> Chris Howden<chris at trickysolutions.com.au>  wrote:
>>> I just installed the new version of R on my machine and Emacs can no
>>> longer
>>> find it. I'm getting the below error message
>> Did it work for a previous installation -- what did you have before in
>> your .emacs?
>>> (note that I tried adding them one at a time)
>>> ;(setq default-inferior-R-program-name "C:/Program
>>> Files/R/R-2.12.0/bin/i386/Rterm.exe")
>> you should have (setq-default ...)
>> rather than (setq default-...)
>> also I assume that the email put the newline between program and files.
>> i.e. I'd try this:
>> (setq-default
>>    inferior-R-program-name
>>    "C:\\Program Files\\R\\R-2.12.0\\bin\\i386\\Rterm.exe")
>> in .emacs and restart.
>> ______________________________________________
>> ESS-help at stat.math.ethz.ch mailing list
>> https://stat.ethz.ch/mailman/listinfo/ess-help

Spencer Graves, PE, PhD
President and Chief Operating Officer
Structure Inspection and Monitoring, Inc.
751 Emerson Ct.
San José, CA 95126
ph:  408-655-4567

More information about the ESS-help mailing list