[ESS] No output in *SAS.lst* with ESS-5.3.5

Rodney Sparapani rsparapa at mcw.edu
Thu Apr 29 16:17:23 CEST 2010

On 04/24/10 09:24 PM, chen jia wrote:
> Hi there,
> I have been using ESS-5.3.5 since 2007 on a Unix server that provides
> SAS. Today, when I ran a SAS program that worked fine last week, I
> could not generate any output in buffer *SAS.lst*.
> Usually, when I run, for example,
> proc contents data = test_data;
> run;
> the output will show up in *SAS.lst*, but it dose not show up now.
> There is no error message from SAS.
> Buffer *SAS.log* seems to work fine.
> Does anyone have any suggestions on what the problem is or how I can
> find out the problem?
> Thanks!
> Best,
> Jia

Hi Jia:

There must be some problem since it doesn't work for me in 5.8 either.
I see..
Debugger entered--Lisp error: (void-function deactivate-mark)
   ess-eval-region(2 24 nil "Eval line")

Of course, there is no such function in XEmacs so somebody must have 
made a boo-boo.  But, do you really want an interactive SAS session? 
Batch is working fine.


More information about the ESS-help mailing list