[ESS] ever see summary() hang Emacs/ESS? I did today, twice!

Rodney Sparapani rsparapa at mcw.edu
Tue May 5 17:45:11 CEST 2009

Paul Johnson wrote:
> My computer lab has Centos 5.3 linux with R-2.8.1 and Emacs 22.2 with Ess 5.3.6.
> I gave the students some regression exercises to work on.  They run lm
> and then summary, nothing fancy.  One student came in and said "Emacs
> crashed" and I went and looked and he was right.  The Gnome-Linux
> session was still ok, but Emacs was just frozen, non responsive.  No
> menus worked, it did not respond to Ctl-g.  I had to use xkill, which
> is a depressing experience, except for the thrill of the little black
> skull and bones and the chance to talk like a pirate and say "Aargh,
> matie". Then I restarted Emacs, R and ran through his code step by
> step and it was all fine.  I ran it over and over, no trouble.  So I
> accused him of doing something evil to make the freeze happen and I
> left.
> About 2 hours later, another student came in.  She was using a
> different PC in the lab, same thing happened.  Emacs was stuck after
> running summary on a linear model. In the terminal from which she ran
> Emacs, there was only the word "KILLED".  I xkilled that one, and
> started running her code step by step, and I was able to reproduce the
> freeze up twice. R would get half way through showing the summary of a
> linear model and stop.  But it did not happen on the exact  same use
> of the summary command in both tests, and after xkill, I restarted
> Emacs and guess what?  Everything worked fine. I ran it through
> several times.
> I wondered if perhaps there could be a corrupted saved R session that
> makes this blow up, but in the working directory there are no hidden
> files at all.
> If you have any ideas, I would be very glad to hear them.  I've not
> had this "Windows System Administrator" feeling in the 10 years since
> I started using Linux.  It is a bummer :)

Well, I rarely use Emacs.  But, crashes with XEmacs aren't as unheard of
as you might hope.  Did Emacs drop core?  If so, then you should be able
to fire up gdb and find the problem.  When XEmacs crashes, it puts all
of the steps that you need to gdb/trace/file a bug report.  But, that
means that you have to have started XEmacs from a terminal.  I assume
that Emacs does the same when started from a terminal.  If this is an OS 
bug, then you are probably toast.  Happy bug hunting!

Rodney Sparapani      Center for Patient Care & Outcomes Research (PCOR)
Sr. Biostatistician              http://www.mcw.edu/pcor
4 wheels good, 2 wheels better!  Medical College of Wisconsin (MCW)
WWLD?:  What Would Lombardi Do?  Milwaukee, WI, USA

More information about the ESS-help mailing list