[ESS] File mode specification error: (void-function run-mode-hook)”.

Rodney Sparapani rsparapa at mcw.edu
Wed Jan 21 16:19:58 CET 2009

Jianjie Ma wrote:
> HI,
> I am new to ESS and Emacs.
> Here is my problem.
> The ESS is put in the directory ~/ess/ess-5.3.10
> In my ~/.emacs file, I added (load "~/ess/ess-5.3.10/lisp/ess-site").
> R is installed in ~/Rlang, the version is 2.8.1.
> Emacs is version21.3.1.
> ESS works and loaded. It works fine for programming and running, that is I
> can start with M-x R and M-x SAS and then program and evaluate codes.
> The problem is when using the auto-mode of Emacs.
> When I open a file, for example, ~/test.R, the R-mode should be
> automatically selected since the "ess-site.el "specified the auto R-mode for
> files with suffix ".R". However I got the error "File mode specification
> error: (void-function run-mode-hook)" though the file can be opened and I
> can still evaluate the R code.
> And also, the highlighting and fonting features are not shown.
> Same Error happened when I tried to open files with suffix ".sas".
> Thanks for your help

Hi Jianjie:

The function run-mode-hook does not exist and also, does not appear
anywhere in the ESS sources that I can find.  The function name is
run-mode-hooks.  But, the error must be some where in the lisp files
distributed with the version of Emacs that you use.  Try upgrading
Emacs.  Hope this helps.

Rodney Sparapani      Center for Patient Care & Outcomes Research (PCOR)
Sr. Biostatistician              http://www.mcw.edu/pcor
4 wheels good, 2 wheels better!  Medical College of Wisconsin (MCW)
WWLD?:  What Would Lombardi Do?  Milwaukee, WI, USA

More information about the ESS-help mailing list