[ESS] help() and library() in R return "... cat: not found"

Martin Maechler maechler at stat.math.ethz.ch
Wed Mar 5 15:27:50 CET 2008

Hi Eiji,

I think none of the ESS developers currently have MacOS X as
their ESS + R "work machine".

So it's hard to help from the developer side.

Can anyone on ESS-help help Eiji?

If not, I'd recommend to post this question
(maybe with slightly more details) to the 
R-SIG-Mac  mailing list.

Martin Maechler, ETH Zurich

>>>>> "NEN" == N Eiji Nawa <globusbogus at yahoo.co.jp>
>>>>>     on Wed, 5 Mar 2008 17:25:44 +0900 (JST) writes:

    NEN> A follow-up to my previous email.
    NEN> When I quit R on ess/emacs, a warning message pops-up that
    NEN> could be related to my problem:

    >> q()
    NEN> Save workspace image? [y/n/c]: n
    NEN> sh: line 1: rm: command not found

    NEN> I don't see that when I quit R running on xterm or the GUI
    NEN> R. Any help is welcome. Thanks a lot!

    NEN> E.

    NEN> --
    NEN> Hello:

    NEN> this is my first post to ess-help (a great software by the
    NEN> way!). I must say first that I am not quite sure my
    NEN> problem can be solved within ess (apologies in advance if
    NEN> that's the case). Let me first describe my system:

    NEN> ess 5.3.6
    NEN> Mac OS X 10.4.11 (G5)
    NEN> GNU Emacs
    NEN> R 2.6.2

    NEN> I am having trouble viewing the R help files from within
    NEN> ess/emacs. This is what happens. When I type

    NEN> help(read.table) 

    NEN> a second buffer (named *help[R](read.table)*) opens up but
    NEN> with an error message

    NEN> /Library/Frameworks//R.framework/Resources/bin/pager: line
    NEN> 10: exec: cat: not found

    NEN> When I type

    NEN> library()

    NEN> I get exactly the same message as above but now in R's
    NEN> main buffer (*R*).

    NEN> Both commands work fine if I run R from a terminal window
    NEN> (like xterm) or from the GUI version of R.

    NEN> What is puzzling me the most is that if I open a shell in
    NEN> emacs, run R, and try help(read.table) or library(), I get
    NEN> the correct results.

    NEN> I first thought it was something related to environment
    NEN> variables, so I first defined R_HOME as
    NEN> /Library/Frameworks/R.framework/Resources but it didn't
    NEN> work. Then I defined R_ENVIRON as
    NEN> /Library/Frameworks/R.framework/Resources/etc/ppc/Renviron
    NEN> but got the same output as before.

    NEN> If you have seen this before or have an idea on how I
    NEN> could nail this down in more details, I will be happy to
    NEN> hear from you.

    NEN> Thank you very much in advance!

    NEN> N. Eiji Nawa

    NEN> ______________________________________________
    NEN> ESS-help at stat.math.ethz.ch mailing list
    NEN> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list