[ESS] How to submit SAS from win XEmacs-ESS on remote UNIX SAS ?

James W. MacDonald jmacdon at med.umich.edu
Tue Sep 25 16:37:15 CEST 2007

Hi Alexandre,

I have never been able to get this to work on Windows (it works no 
problem on MacOS and I am sure *nix). What I ended up doing is 
installing PuTTY and Xming on my Windows box, setting PuTTY up to do X11 
forwarding and then running Emacs on the remote box.

You end up getting a reasonable looking Emacs on the Windows box that 
you can interact with just as if it were running locally, and obviously 
you can then submit commands to SAS. Unfortunately this only works if 
you can a.) install Emacs (or Xemacs, I suppose) on the remote box, and 
b.) that X11 forwarding is enabled on the remote box as well.

More details can be found here:


Alexandre Zolotovitski wrote:
> In accordance to
> ess.pdf: *"1. Start a new telnet or ssh buffer and connect to the remote
> computer (e.g. use `M-x*
> *telnet' or `M-x ssh'; ssh.el is available at
> ftp://ftp.splode.com/pub/users/friedman/emacs-lisp/ssh*
> *Chapter 3: Interacting with statistical programs 21*
> *2. Start the ESS process on the remote machine, for example with one of the
> commands*
> *`Splus', or `R', or `sas -stdio'.*
> *3. Enter the ESS command `M-x ess-remote'"*
> *
> *I got ssh.el and included there text*
> *
> ;;; az (defcustom ssh-program "ssh"
> ;;;   "*Name of program to invoke ssh"
> ;;;(defcustom ssh-program "C:/Program Files/SSH Communications Security/SSH
> Secure Shell/SshClient.exe"
> (defcustom ssh-program "C:/Progra~1/SSHCom~1/SSHSec~1/SshClient.exe"
>   :type 'string
>   :group 'ssh)
> ;;; (defcustom ssh-explicit-args '()
> ;;;  "*List of arguments to pass to ssh on the command line."
> ;;;(defcustom ssh-explicit-args '("-h" "sr1-usca-04.sfbay.sun.com"
> "C:/Documents and Settings/Alex/Application Data/SSH/sfbay 04.ssh2")
>  (defcustom ssh-explicit-args '("sfbay-04.ssh2")
>   :type '(repeat (string :tag "Argument"))
>   :group 'ssh)
> I tried to use commented lines and to include ssh profile name sfbay-04.ssh2
> in (defcustom ssh-explicit-args) as well instead of (defcustom
> ssh-program) with
> the same result: after *`M-x ssh'  *I got request for ssh arguments and
> message Symbol's value as variable is void: ssh-explicit-args  and no ssh
> buffer or other ssh process to run *'sas -stdio'  on the remote mashine.*
> Thank you,
> Alex Z
> *
> *
> Richard M. Heiberger wrote:
> Please see the relevant section of documentation, 10 ESS for SAS,
> in the file
> .../ess/doc/html/ess.html
> If that doesn't seems sufficient, then please send to this list information
> on exactly what you tried and exactly what the system gave back to
> you.

More information about the ESS-help mailing list