[ESS] Problem with R 2.6.0 "Lisp nesting exceeds max-lisp-eval-depth"

Bill.Venables at csiro.au Bill.Venables at csiro.au
Mon Nov 5 00:34:13 CET 2007

I'm getting a strange problem with R-2.6.0 on one of my machines, but
curiously not the other.  Both are Windows (sadly).

I used to start R with \M-x R-2.5.1  and it worked fine on both

When I uninstalled R-2.5.1 and installed R-2.6.0 on both machines, one
still worked fine, but the other just gives the message

"Lisp nesting exceeds max-lisp-eval-depth"

Has anyone had this problem?  Does it suggest anything?  I'm a bit

If I start a bash shell within Emacs and then start R using Rterm
--save, it works OK, but of course this does not link to ESS.

I'm using Emacs 21.3.1 (i386-mingw-nt5.1.2600) of 2004-03-11 on NYAUMO
on both machines.


Bill Venables
CSIRO Laboratories
PO Box 120, Cleveland, 4163
Office Phone (email preferred): +61 7 3826 7251
Fax (if absolutely necessary):  +61 7 3826 7304
Mobile:                         +61 4 8819 4402
Home Phone:                     +61 7 3286 7700
mailto:Bill.Venables at csiro.au

More information about the ESS-help mailing list