[ESS] Emacs on Gentoo can't find ESS when starting in a Konsole (KDE xterm)

Charles C. Berry cberry at tajo.ucsd.edu
Wed Jan 24 02:58:51 CET 2007

'konsole' is not exactly 'xterm'

I run R version 2.4.1 (2006-12-18), ESS 5.3.3, on gentoo
( 2.6.18-gentoo-r6 #4 SMP ... x86_64 Intel(R) Xeon(R) CPU  ) at the 

I cannot try konsole right now because I am off-site, but starting emacs 
from 'Run' dialog, I was always able to 'M-x R' with no problems. 
Likewise, I can ssh from off-site, start emacs, and 'M-x R'.

I have

 	(load "<path-to-ess-site>/ess-site")

in my $HOME/.emacs file as suggested in



Chuck Berry

On Wed, 24 Jan 2007, Anthony Staines wrote:

> Hi,
> I have used ESS and Emacs to work with R for some time. I recently updated to R
> 2.4.1, and ESS has stopped working. When I start emacs, by typing emacs & in a
> Konsole window, emacs starts, but ESS is not loaded.
> Following the kind advice of Stephen Eglen to another enquirer
> (See
> http://search.gmane.org/?query=M-x%20%20%5bno%20match%5d&group=gmane.emacs.ess.general)
> -->Has ess been loaded - it seems not?  To see if it has, do "C-h v
> -->features" and see if ess-site is in the list.
> -->
> -->If not, try
> -->"M-x locate-library ess-site" to see if Emacs can find ess-site.  If
> -->it can find the lib, but it hasn't been loaded, do
> -->"M-x load-library ess-site"
> -->
> -->and try M-x R again.
> I established that ESS was not loading, that emacs could indeed find the ESS
> library, and that when it was manually loaded, 'M-x R' worked fine. However,
> when I restart emacs I still have to load ESS by hand.
> The /usr/share/emacs/site-lisp directory has three files, as below, and the ess
> subdirectory.
> The relevant configuration files are below -
> site-lisp # cat 50ess-gentoo.el
> ;;; Emacs Speak Statistics site-lisp configuration
> (add-to-list 'load-path "/usr/share/emacs/site-lisp/ess")
> (require 'ess-site)
> site-lisp # cat site-gentoo.el
> ;;; -----------------------------------------------------------------
> ;;; Emacs Speak Statistics site-lisp configuration
> (add-to-list 'load-path "/usr/share/emacs/site-lisp/ess")
> (require 'ess-site)
> site-lisp # cat site_start.el
> (load "/usr/share/emacs/site-lisp/site-gentoo")
> Any thoughts on how to get ESS automatically loaded on starting emacs?
> Ta,
> Anthony Staines
> ______________________________________________
> ESS-help at stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/ess-help

Charles C. Berry                        (858) 534-2098
                                          Dept of Family/Preventive Medicine
E mailto:cberry at tajo.ucsd.edu	         UC San Diego
http://biostat.ucsd.edu/~cberry/         La Jolla, San Diego 92093-0901

More information about the ESS-help mailing list