[ESS] making sure proper ~/.emacs is loading

Mark W Kimpel mwkimpel at gmail.com
Tue Apr 3 05:32:15 CEST 2007

I am running emacs/ess on openSuse 10.2. I thought Sven's idea for 
showing function arguments was great and tried to implement it, the 
first time I have tried to customize my emacs/ess installation. When I 
went to my ~/.emacs file, I saw the code below:

;; Custum Settings
   ;; ===============
   ;; To avoid any trouble with the customization system of GNU emacs
   ;; we set the default file ~/.gnu-emacs-custom
   (setq custom-file "~/.gnu-emacs-custom")
   (load "~/.gnu-emacs-custom" t t)

I took this to indicate that I should not be changing the .emacs file 
itself, but that I should create my own .gnu-emacs-custom file and place 
the custom code in that. After I did that, I couldn't get Sven's tools 
to work. I then tried appending Sven's code to the .emacs file and 
again, the tools didn't work.

I am a newbie emacs user. One of the first things I can think of to test 
would be to make sure that the above files are actually loading, not 
some files in another directory. Is there anything easy that I could put 
in the appropriate file (.emacs or .gnu-emacs-custom, you tell me) that 
would let me know if the file has loaded into emacs or not?

I am sure this is my mistake, not a problem with Sven's code, so if 
anyone could suggest where I should start, I'd be grateful.

Mark W. Kimpel MD
Department of Psychiatry
Indiana University School of Medicine

More information about the ESS-help mailing list