[ESS] rdired stopped working

Henning Redestig redestig at mpimp-golm.mpg.de
Tue Nov 8 11:23:09 CET 2005

I know its very weird, because it worked fine for me up until just 
recently. I have not changed any language settings, my linux is in 
german and so is my R. This has not (and should not I suppose?) caused 
any problems before.. I wouldnt assume this is a bug in ess-rdired but 
something thats gone wrong with my system. I just can not even speculate 
on what that might be... I found rdired a very nice interface to 
managing the R workspace and dont know of any alternative for this task.

Thanks alot,


Stephen Eglen wrote:
>  > when I do ess-rdired I get: 
>  > 
>  > Error in parse(file, n, text, prompt) : Parsing error 
> umm.  I just tested it (although I wrote it, I don't use it often) and
> it seems fine here.
>  > until recently rdired worked just fine for me so I am
>  > having a very hard time understanding how this could have happened. I
>  > havent made any changes recently to my system. I upgraded ESS to
>  > 5.2.10 but that did not solve the problem. Also a problem that arose
>  > about the same, making me thinking they are related, is that when I do
>  > ess-load-file it doesnt load as usually but prints out some seemingly
>  > random snippet of the file, e.g. this what it could look like in my
>  > R-buffer when I try to load a file with 297 lines:
> Ummm; this is really odd.  The only thing I can think of is that in
> your email, there were lots of control chars (\200 \230 \231).  Have
> you recently changed any language settings?
> sorry I can't help more!
> stephen

More information about the ESS-help mailing list