emacs key bindings: normal .emacs entries don't work

John Bullock john.bullock at stanford.edu
Mon Oct 4 04:12:50 CEST 2004


        I use GNU Emacs 22.1 -- via a tty terminal, not through X.
I am trying to change the default key bindings so that (for example) 
Control-right moves the cursor forward by one word.  Newsgroups are full of 
solutions to this problem, but to date, none of them have helped me.

        I've tried each of these lines in .emacs:

                (global-set-key (quote [C-right]) (quote forward-word))
                (global-set-key [C-right] 'forward-word)
                (global-set-key [(control right)] 'forward-word)

None have worked.  In addition, I tried

                (global-set-key [?\C-right] 'forward-word)

but this, apparently, isn't valid.

Incidentally, I don't have this problem when I run emacs under X -- only when 
I try to run it from a terminal.  Is it likely that the problem lies not with 
my .emacs file but with some setting of my terminal?


More information about the ESS-help mailing list