error while starting R und XEmacs

Stephen Eglen stephen at
Sun Feb 22 15:28:01 CET 2004

hi Thomas,

 > I just installed Redhat Fedora (I'm new on unix-like systems) and
 > tried to start R in XEmacs 21.5.b16.

 > I installed all XEmacs-Packages (sucessfully, I hope so) and put 
 > (require 'ess-site) in my init.el.
 > After typing M-x R the following error-message occurs:
 > Invalid state: Bogus value for 'default-process-coding-system', nil

Okay, a few things might help us here.

Do you have access to Emacs (21.2 or 21.3)?  If so, could you try it
on there and see if you get the same error?  I think that error sounds
like an XEmacs specific thing.  

Also, I can run ESS/R on XEmacs 21.4 (patch 12), can you try an older
version of XEmacs?  It looks like you are running a new release of
XEmacs, which we might need to look at.

Also, backtraces can help us debug the problem further.  Type
"M-x set-variable RET debug-on-error RET t RET".  Then type the
command that causes the error ("M-x R" here) and you should see a
*Backtrace* buffer containing debug information; send us that buffer.


More information about the ESS-help mailing list