debian unstable update and emacs looses R

Angel Lopez angel_lul at
Wed Aug 25 11:53:22 CEST 2004

Spot on.
Thanks, I had a problem on my emacs and ess installation (I think it was 
due to the emacs-goodies package).
Solved now.
Thanks again.

Stephen Eglen wrote:
>  > I've updated my debian linux unstable this week. After the update 
>  > everything is fine except for emacs not being able to open an R session, 
>  > when I type M-x R , I get a [No match] reply in the minibuffer. R 
>  > installation is fine (i.e. typing R in bash starts R normally) and I've 
>  > also tried running emacs as root but the problem is still there.
>  > Emacs version is 21.3.1
>  > BTW with other programs (e.g. M-x maxima) works fine so it seems to be 
>  > an R only problem.
> Has ess been loaded - it seems not?  To see if it has, do "C-h v
> features" and see if ess-site is in the list.
> If not, try 
> "M-x locate-library ess-site" to see if Emacs can find ess-site.  If
> it can find the lib, but it hasn't been loaded, do 
> "M-x load-library ess-site"
> and try M-x R again.
> Stephen
> .

More information about the ESS-help mailing list