cannot start R from emacs

Pawel pgajer at
Fri Apr 16 22:14:53 CEST 2004

I have read the messages on the same subject in the ess-help archives 
from March of 2004 and I have made the suggested changes, yet the 
problem is still there.

I am running Mac OS X 10.3.3,  GNU Emacs, ESS-5.1.21 (with 
ess-site.el that worked on my linux box)
relevant lines from my .emacs.el file

(load "/usr/local/lib/lisp/ess-5.1.21/ess-site")
(setq-default inferior-R-program-name "/usr/local/bin/R --save")

when executing M-x R, R does not start, but in the *R* buffer I get a 

Can't exec program: /usr/local/bin/R --save
Process R exited abnormally with code 1 at Fri Apr 16 15:58:21 2004

without --save option, R also does not start and the message reads

Fatal error: you must specify `--save', `--no-save' or `--vanilla'
Process R exited abnormally with code 2 at Fri Apr 16 15:57:46 2004

I also tried to use --vanilla instead of --save, with the same result.

I can run start R from emacs' shell, executing R --save or R --vanilla, 
but I don't see the prompt sign '>' and only when entering a command 
the result has the prompt, but the line where the cursor is, has no '>' 

I would greatly appreciate any comments or suggestions

More information about the ESS-help mailing list