problems using SAS mode

A.J. Rossini rossini at
Fri Nov 21 01:41:02 CET 2003

Faheem Mitha <faheem at> writes:

> Dear People,
> I am trying to figure out how to use SAS with ESS. I have never tried to
> do so before, and am having some trouble. I have previously used ESS with
> R.
> Hopefully I am making some stupid errors which can be easily corrected.
> I am first trying to run SAS in batch mode as per the instructions in
> Note that SAS runs fine both from a regular shell and on a shell from
> inside emacs.
> I added the line
> (setq ess-sas-local-unix-keys t)
> to my .emacs.
> I then opened a sas test file in emacs as follows.
> **************************
> DATA distance;
> miles = 23;
> kilometr = 1.61*miles;
> PROC PRINT DATA = distance;
> RUN;
> **************************
> I then hit F3 as instructed to run the program in SAS mode. I just got
> a beep. None of the other function keys did anything. I suppose it is
> likely that I do not have the right thing in my .emacs file. I am
> reluctant to modify the system files since this would break on an
> upgrade.

If you do C-h b  (show bindings), what are the F# keys bound to?  This
approach should work, so I'm a bit confused.

> I have different problems with interactive SAS mode.

I have many problems with it :-).   I'm not sure how well it works;
Rich has used it before, I've used it before, but it hasn't worked for
me recently, and I suspect it might need to be deprecated.

rossini at   
Biomedical and Health Informatics   University of Washington
Biostatistics, SCHARP/HVTN          Fred Hutchinson Cancer Research Center
UW (Tu/Th/F): 206-616-7630 FAX=206-543-3461 | Voicemail is unreliable
FHCRC  (M/W): 206-667-7025 FAX=206-667-4812 | use Email

CONFIDENTIALITY NOTICE: This e-mail message and any attachme...{{dropped}}

More information about the ESS-help mailing list