C-c C-d with new R functions

S.McClatchie s.mcclatchie at niwa.cri.nz
Wed Feb 27 02:24:32 CET 2002

System info:
R Version 1.4.1  (2002-01-30) on Windows 2000
ESS v. 5.1.20 using emacs ver. 20.1.1


Using the new ess-site.el corrected for the C-c C-l problem, I am now 
having a problem with C-c C-d, but only for new functions in R. Dumping 
a pre-existing function is working fine. 

However, when I use C-c C-d to dump a new function, an error results 
(Wrong type argument: stringp nil).

So I tried creating a test function, 

ts.vs.area <- function()

saving it in the /R-src directory, as 


and loading the test file using C-c C-l. 

ESS asked me for the process to load the function into (R) and then did 
so successfully. Re-dumping the function with C-c C-d then worked fine, 
as did C-c C-l. 

Is there a problem here? Or am I doing something incorrectly?



Thanks for the help,
Sam McClatchie, 
Research scientist (fisheries acoustics))))))))))

NIWA (National Institute of Water & Atmospheric Research Ltd)
Postal address: PO Box 14 901, Kilbirnie, Wellington, New Zealand. 

Street address: 301 Evans Bay Parade, Greta Point, 6003 Wellington, New Zealand.

Email: s.mcclatchie at niwa.cri.nz, 
phone 64-04-386-0574, FAX: 64-4-386 0574. 

...>><xX(°> // \\
                 /// \\\   
                //// \\\\
               ///  <°)Xx><<
              /////  \\\\\\
  >><(((°>   ...>><xX(°>O<°)Xx><<

ess-help mailing list -- To (un)subscribe, send
subscribe	or	unsubscribe
(in the "body", not the subject !)  To: ess-help-request at stat.math.ethz.ch

More information about the ESS-help mailing list