ESS and S+6 on Windows NT

Gerald.Jean at Gerald.Jean at
Mon Oct 1 17:44:35 CEST 2001

Sorry, I forgot the "object" on the previous mail,


I have been running Splus-2000 under ESS (5.1.19 at this time) for
sometimes now, and have been pretty happy with it.  I installed S+6
yesterday and I am still trying to run it from ESS with mixed luck.  I am
on an NT4.0, rp5 machine with dual processors (500MHz) with 1G of RAM,
Emacs 20.6, ESS 5.1.19; the S+6 executable is in
"C:\Program Files\Insightful\splus6\cmd\".  Here is what I have done so

1) I tried to strart S+6 using the command "M-S+6", it worked but
Splus-2000 started rather than S+6.

2) In my ".emacs" file I inserted the following lines an recompiled it:

(setq-default inferior-S+6-program-name "c:/Progra~1/Insightful/splus6/cmd/SPLUS")
(setq-default inferior-Sqpe+6-program-name
(setq-default inferior-Sqpe+6-SHOME-name "c:/Progra~1/Insightful/splus6")

Now giving the command "M-S+6" starts S+6, the GUI thing, OK, but all S+
output goes to the "ddeESS [S+6]" buffer, nothing appears in the S+ window,
except the commands I send from the "myfile.s" file; even going directly,
in the supposedly independent, S+ process, all output goes to the ESS
buffer??  Here is the content of the "S+6" buffer after the commands:

> objects()
> objects()
> ttt_23
> ttt
> search()

*********** Start of buffer
This is a placeholder buffer.  You can't type anything here.
Use `C-x b RET' to return to your file.

Anything sent to this process from an S-mode buffer goes
directly to the associated Splus Commands window.

The S-Plus Commands window must be visible.
You may need to open the S-Plus Commands window manually (by clicking on
Splus/Window/Commands Window).

Any results of the   !system.command   typed at the S prompt in the
Splus Commands window appear in this buffer.

$ c:/Progra~1/Insightful/splus6/cmd/SPLUS /MULTIPLEINSTANCES S_PRINT_COMMAND=gnuclientw.exe S_PROJ=d:/Donnees/splus6/users/JEG002
S-PLUS : Copyright (c) 1988, 2001 Insightful Corp.
S : Copyright Lucent Technologies, Inc.
Professional Edition Version 6.0.3 Release 2 for Microsoft Windows : 2001
Working data will be in d:\Donnees\splus6\users\JEG002
[1] "d:\\Donnees\\splus6\\users\\JEG002\\.Data"
[1] ".Last.value"
[1] ".Last.value"
[1] 23
*************** End of buffer ********************************

Another irritant:

Every time I start S+ from Emacs, and this had been the case from the
beginning with Splus-2000 as well, I get the following S-plus Utility Error
panel showing up, I click the OK button and from then it works OK, any idea
why is this occuring?  The utility panel says:

"Error opening BATCH input file

This directory is where my ".data" and ".pref" files reside.  I always
"dired" to that directory and start S+ from there, once started I have my
own functions to navigate through directories.  What annoys me the most in
that behaviour is to have a colleague standing by to see a graph or
something while I start S+ from Emacs, and comenting on the software I use,
they are all pretty impressed by the connectivity of Emacs and Splus, that
is, until they see that Utility Error panel showing up!!!  This doesn't
happen when I start S+ by clicking directly on its icon??

A positive note to finish: Sqpe+6 seems to work OK.

Any and all help appreciated, thanks,

Gérald Jean
Analyste-conseil (statistiques), Actuariat
télephone            : (418) 835-4900 poste (7639)
télecopieur          : (418) 835-6657
courrier électronique: gerald.jean at

"In God we trust all others must bring data"  W. Edwards Deming

ess-help mailing list -- To (un)subscribe, send
subscribe	or	unsubscribe
(in the "body", not the subject !)  To: ess-help-request at

More information about the ESS-help mailing list